Old But New - S2000 Forums


New s2000.com Member Area / Introductions Are you new to S2000.com? WELCOME! Check in, tell us about yourself and your ride.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 11-07-2017, 12:28 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2017
Location: O C
Posts: 5
Old But New

Long time Honda owner, but this is my 1st 2001 S2000 red low miles, I have had this ride for 3 months now this is my fun car my everyday car is a 2009 Honda fit over 100K
my S2000 is having some speedometer problems bump in the road make it malfunction some times streets or highways most of the time it starts when I am just cursing driving at 40 or 50 then the speedo reads 7 or 3 or 0for a few seconds then it s up and down.
Any suggestions?
EZ-AL is offline   Reply With Quote
Old 11-07-2017, 02:58 PM   #2
Senior Member
 
chazdawg35's Avatar
 
Join Date: Jul 2007
Location: Mojave Dessert CA
Posts: 3,405
Hope your enjoying your S2K i had one back in the day with a similar problem. My speedo was flickering on and off turned out to be a bad diode in the alternator you might want to check that out. Other than that it's a great and fun car, I'm still kicking myself for selling it but at the time California smog forced me too.
chazdawg35 is offline   Reply With Quote
Old 11-07-2017, 03:26 PM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2017
Location: O C
Posts: 5
Smile Thanks for the tip

Ill check it out .
Thanks Alan
By the way your a Senior?
Me too
EZ-AL is offline   Reply With Quote
Old 11-07-2017, 06:09 PM   #4
8 Hours NE of the Dragon
 
kgf3076's Avatar
 
Join Date: Oct 2006
Location: Not where your are, obviously.
Posts: 5,128
Quote:
Originally Posted by EZ-AL View Post
Ill check it out .
Thanks Alan
By the way your a Senior?
Me too
Nah, just means he posts a lot here. Don't remember the crossover point for number of posts, but hang around and contribute and one day you're a senior senior.
kgf3076 is offline   Reply With Quote
Old 11-08-2017, 06:31 AM   #5
THE STIG
 
Switchblade's Avatar
 
Join Date: May 2010
Location: NAZARETH, PA
Posts: 8,403
Welcome! I hope it's an easy fix!
Switchblade is offline   Reply With Quote
Old 11-11-2017, 07:23 AM   #6
Senior Member
 
ZigZag's Avatar
 
Join Date: May 2009
Location: Close to the twisties in Glacier Park
Posts: 353
Welcome. Let us know what the fix was when you get it figured out. Seems we are all driving old cars here.
ZigZag is offline   Reply With Quote
Old 11-11-2017, 04:17 PM   #7
Senior Member
 
chazdawg35's Avatar
 
Join Date: Jul 2007
Location: Mojave Dessert CA
Posts: 3,405
Quote:
Originally Posted by EZ-AL View Post
Ill check it out .
Thanks Alan
By the way your a Senior?
Me too
Not a Senior Citizen YET! but getting up there. I would like to hear the fix for your problem, as I'm a mechanic and very familiar with the S2K and Honda cars them self.
chazdawg35 is offline   Reply With Quote
Old 11-11-2017, 06:11 PM   #8
Junior Member
Thread Starter
 
Join Date: Nov 2017
Location: O C
Posts: 5
Smile Small fix or check to do if you have Speedometer Trouble

I am a Senior I am 70 with my 1st S2000 red low miles 24000. SO far the only major fix to check all you ground connections from frame to the ground blocks you might have to maybe add a star washer to get a better ground to the frame and check all pin connections to make sure good contact and not lose. mine were lose plus poor ground contact to frame. So far so good speedometer is working fine no malfunctions. not the VVS or the ECU.
I am guessing just over time and vibrations poor ground and lose connections this happened. Hope this is helpful to all.
Good Luck Alan

Last edited by EZ-AL; 11-11-2017 at 06:14 PM.
EZ-AL is offline   Reply With Quote
Old 11-11-2017, 08:29 PM   #9
8 Hours NE of the Dragon
 
kgf3076's Avatar
 
Join Date: Oct 2006
Location: Not where your are, obviously.
Posts: 5,128
Quote:
Originally Posted by EZ-AL View Post
I am a Senior I am 70 with my 1st S2000 red low miles 24000.
Welcome to the S2000 world. I'm 73 and have two at the moment, an AP-1 and a 2008 CR. Owning them can be an (expensive) addiction.
kgf3076 is offline   Reply With Quote
Old 11-11-2017, 10:43 PM   #10
Junior Member
Thread Starter
 
Join Date: Nov 2017
Location: O C
Posts: 5
My other Honda is a 2009 fit Sport my gas saver

I live on the West coast these events are a bit of a ride trying to keep the miles low on the S2000 Ill wait for a local event I plan to take ride on Hwy.1 for a few days.
A real test for the speedometer and my wife loves to drive the S2000 she is very good behind the stick, Not a road racer or a drag racer but she can handle a stick very well.
The wife is 69 but love her GLK350 2015 better for driving in traffic on the Freeways
EZ-AL is offline   Reply With Quote
Old 11-13-2017, 04:10 PM   #11
Junior Member
Thread Starter
 
Join Date: Nov 2017
Location: O C
Posts: 5
Quote:
Originally Posted by ZigZag View Post
Welcome. Let us know what the fix was when you get it figured out. Seems we are all driving old cars here.
SO far the only major fix to check all you ground connections from frame to the ground blocks you might have to maybe add a star washer to get a better ground to the frame and check all pin connections to make sure good contact and not lose. mine were lose plus poor ground contact to frame. So far so good speedometer is working fine no malfunctions. not the VVS or the ECU.
I am guessing just over time and vibrations poor ground and lose connections this happened. Hope this is helpful to all.
Good Luck Alan[/QUOTE]
EZ-AL is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
102-Year-Old Woman Still Drives Her 82-Year-Old Car RMurphy Off-Topic 13 11-13-2012 01:31 AM
Kind of New/Old ras31 New s2000.com Member Area / Introductions 3 12-10-2008 12:47 PM
New member, old owner. mbc New s2000.com Member Area / Introductions 22 06-19-2008 10:10 AM
New to the S2K, old to Honda F4ipilot New s2000.com Member Area / Introductions 4 11-19-2007 11:32 AM
New member with old 2000 Berlina LivingDeadS2K New s2000.com Member Area / Introductions 12 10-15-2007 10:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.