New s2000.com Member Area / Introductions Are you new to S2000.com? WELCOME! Check in, tell us about yourself and your ride.

New to site, need help

Old 04-10-2015, 02:52 PM
  #1  
Junior Member
Thread Starter
 
Dat Nguyen's Avatar
 
Join Date: Apr 2015
Posts: 2
New to site, need help

So i own an ap1 2001, with an ap2 motor swap. have the car for less than a year. Recently Ive been having no crank, no start, issues. already took the starter off to test. starter and starter solenoid is in good working condition. the tech told me to double check my wires and connecters.... Any one else have this issue??
Dat Nguyen is offline  
Old 04-10-2015, 03:20 PM
  #2  
Never Slow down
 
Wayne's Avatar
 
Join Date: Dec 2009
Location: ON Canada
Posts: 1,174
So you turn the key and nothing? Start with the battery, then look at the ignition switch, after that the wiring...
Wayne is offline  
Old 04-10-2015, 06:01 PM
  #3  
Junior Member
Thread Starter
 
Dat Nguyen's Avatar
 
Join Date: Apr 2015
Posts: 2
Originally Posted by Wayne View Post
So you turn the key and nothing? Start with the battery, then look at the ignition switch, after that the wiring...
thanks bro, ill start with that before i touch into the wiring
Dat Nguyen is offline  
Old 04-11-2015, 07:39 AM
  #4  
Never Slow down
 
Wayne's Avatar
 
Join Date: Dec 2009
Location: ON Canada
Posts: 1,174
Good luck!
Wayne is offline  
Old 04-11-2015, 10:01 AM
  #5  
Senior Member
 
flyingarmadillo's Avatar
 
Join Date: Jul 2008
Location: Houston Texas
Posts: 754
Originally Posted by Dat Nguyen View Post
So i own an ap1 2001, with an ap2 motor swap. have the car for less than a year. Recently Ive been having no crank, no start, issues. already took the starter off to test. starter and starter solenoid is in good working condition. the tech told me to double check my wires and connecters.... Any one else have this issue??

Check your ground cable for "Black Rot" - it's corrosion under insulation. Or better, just replace your ground cable - it's a cheap fix (<$20).
flyingarmadillo is offline  
Old 04-13-2015, 05:36 AM
  #6  
THE STIG
 
Switchblade's Avatar
 
Join Date: May 2010
Location: NAZARETH, PA
Posts: 8,317
Good luck!
Switchblade is offline  
Old 04-23-2015, 03:02 AM
  #7  
Junior Member
 
axeler8's Avatar
 
Join Date: Apr 2015
Posts: 24
Just joined here, looked at your ride and its good looking man.
axeler8 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
brandonjay_1983
South West
7
04-28-2011 10:20 AM
yoko-loco
New s2000.com Member Area / Introductions
4
03-31-2010 05:13 PM
red00s2k
New s2000.com Member Area / Introductions
14
02-09-2009 10:36 AM
TerpCop56
New s2000.com Member Area / Introductions
14
03-29-2008 02:05 PM
Chrisbert
New s2000.com Member Area / Introductions
2
06-07-2007 04:05 PM


Thread Tools
Search this Thread
Quick Reply: New to site, need help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.