Code P0411 - New correct placement

Old 10-02-2018, 05:20 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2018
Posts: 4
Code P0411 - New correct placement

I was getting a P0411 code on my 2005 S2000 which according to the OBD I ran is Secondary Pulse Air Injection - Incorrect Flow . I cleared it but every 10 miles it would return . I could discern no problems with the drivability. I looked under the hood to see if any hoses were loose and lo and behold I found a small hose underneath the serpentine belt. It was chewed in half . I removed it with mild difficulty and it had enough length to reconnect to a small box with a second hose. It must have had a bracket that came off and fell into the belt . The code has not come back after more than 100 miles so that's good but I don't know where to reattach the small box . If you look at my picture you will see I kinda used some electrician's tape and pulled it up close to the airbox. But I don't want to leave it like this . The tape will eventually fail and it will look pretty bad if I go to an oil change place. There is a small threaded hole directly in the middle of the picture I attached. I kinda of think it might go there but am unsure how . If anyone can help me without remarking on my obvious jury rigging I would greatly appreciate it. Thanks , Tom
P.S I hope I uploaded this picture correctly
Attached Thumbnails Click image for larger version

Name:	IMG_20181002_120023393.jpg
Views:	22
Size:	4.07 MB
ID:	12885  
montytw is offline  
Old 10-04-2018, 05:48 AM
  #2  
THE STIG
 
Switchblade's Avatar
 
Join Date: May 2010
Location: NAZARETH, PA
Posts: 8,315
Hey Tom, do you see where it looks like a bolt would go on the air box right next to the little "black box" you have rigged up? It gets attached there. Not sure if just a bolt missing or if it snapped off but it goes there.
Switchblade is offline  
Old 10-29-2018, 01:49 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Oct 2018
Posts: 4
I thought that but mine must be missing a bracket because there is noting on mine that i could put a bolt thru.
montytw is offline  
Old 10-30-2018, 07:03 AM
  #4  
THE STIG
 
Switchblade's Avatar
 
Join Date: May 2010
Location: NAZARETH, PA
Posts: 8,315







Some more pics to help you.
Switchblade is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
marshall
Forced Induction / Nitrous
4
06-16-2013 02:12 PM
asimdada
South
4
04-30-2013 08:36 AM
fresh06ap2
Interior / Audio / Electronics
7
11-08-2012 08:05 AM
MaCkStRaP85
Engine Tech / Drivetrain
10
07-28-2009 04:31 PM
Honda007
Exterior / Detailing / Body Work
0
07-25-2008 10:54 PM


Thread Tools
Search this Thread
Quick Reply: Code P0411 - New correct placement


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.