All Other Honda S2000 Related Discussions Share your knowledge, experience and info about Honda S2000

Idle speed

Old 12-08-2004, 02:49 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2004
Posts: 304
Idle speed

Hi, my car is 2004, and i ve been havinf this prblem since i bought the car. My car will drop below the idle speed when i come to a stop, that is when you are is still moving and maybe in 3 or 2nd gear and u stop at a red light, the rev drop blow the idle rev. and then it pops back up to normal rev. So i am wondering if this is a normal thing for s2000?

thx
wowowox is offline  
Old 12-08-2004, 07:48 AM
  #2  
Member
 
Join Date: May 2003
Location: Lendelede Belgium
Posts: 87
If it comes back to normal don't worry.
El Animali is offline  
Old 12-08-2004, 01:22 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Aug 2004
Posts: 304
thx for your reply, just curious does all manul cars have this problem ?
wowowox is offline  
Old 12-17-2004, 05:00 AM
  #4  
Junior Member
 
Join Date: Aug 2004
Posts: 9
My 04 does the same thing. As I come to a stop, usually from 2nd or 3rd gear, the engine drops very low and almost stalls. It has never actually stalled, though. I'm not too worried about it. I have double checked to make sure that I have the clutch fully engaged, so it isn't anything I have done.
Evinrude is offline  
Old 12-28-2004, 08:46 AM
  #5  
ACE
Junior Member
 
ACE's Avatar
 
Join Date: Dec 2004
Posts: 20
Realx

Nothing wrong whatsoever dude! That is normal in any stick shift. (well at least the last 8 I had all did it)
ACE is offline  
Old 04-22-2010, 05:25 AM
  #6  
Junior Member
 
Join Date: Apr 2010
Posts: 2
Hello,

please allow me reply to this thread because i unfortunately have same problem but my engine stops

Like in first post ... if i have gear there .. 2 .. 3 .. 4 ... everything is ok, but if step on clutch and put neutral there, revs go lower then 800rpm and my engine stops

When there is cold engine and revs are above 1000 rpm everything is ok and engine warms up itself and revs drops to 800 but when i try move car and add throttle and then i release throttle revs drops below 800 and engine stops.

I tried replace air filter, because i had prelude before my s2000 and i had same rev problem like wowowox wrote in first post and problem was solved.

When i replaced paper air filter i putted there KN and it was ok for few days, but yesterday it happened again and looks like it is doing more often.

Im very sad of that and i really dont know where can be problem, if someone can help me or if someone had same problems and solved it i would be very thankful for any help
hyipik is offline  
Old 04-23-2010, 12:38 AM
  #7  
Senior Member, Literally
 
philiam's Avatar
 
Join Date: Sep 2007
Location: woodland hills, CA
Posts: 4,442
You're not giving it enough gas when you let the clutch out and it's stalling. Try blipping the throttle to keep the revs up as you let the clutch out. Been driving stick shift all my life and still had to get use to starting up at first.
philiam is offline  
Old 04-25-2010, 06:33 PM
  #8  
Junior Member
 
Join Date: May 2009
Posts: 3
My '04 has never acted that way. Are you saying that with either the clutch depressed or in neutral when coming to a stop the engine won't maintain idle and stalls? If so, it sounds like something is wrong to me.
jpkcguy is offline  
Old 04-25-2010, 09:52 PM
  #9  
Senior Member
 
desmo4's Avatar
 
Join Date: Oct 2007
Location: San Jose, CA
Posts: 1,766
This is not a ordinary car. The ECU deals with an extended rpm range. When you come to a stop you should be in gear until below 10 mph. If you coast to a stop above this you confuse the ecu. And that is why the rpm drops. If it stalls you have other problems.

Jonathan
desmo4 is offline  
Old 05-08-2012, 10:47 AM
  #10  
Junior Member
 
L()veMyS2K's Avatar
 
Join Date: May 2012
Location: An enigma wrapped inside of a labyrinth
Posts: 3
Smile thanks desmo4

you answered a question I hadn't asked yet. haha
I am new to the s2k world, had my baby for 3weeks.
I am proud to be an owner!!!!!
wanted this car since The Fast and The Furious came out!
L()veMyS2K is offline  
Old 05-08-2012, 05:56 PM
  #11  
Senior Member, Literally
 
philiam's Avatar
 
Join Date: Sep 2007
Location: woodland hills, CA
Posts: 4,442
Part of the cause is the use of a light flywheel. I think they used a heavier one in the AP 2's
philiam is offline  
Old 05-09-2012, 05:22 AM
  #12  
THE STIG
 
Switchblade's Avatar
 
Join Date: May 2010
Location: NAZARETH, PA
Posts: 8,324
Originally Posted by philiam View Post
Part of the cause is the use of a light flywheel. I think they used a heavier one in the AP 2's
You are correct sir. I'm pretty sure the AP1 flywheels are 14lbs. and AP2s are 22 lbs.
Switchblade is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hondabim
Forced Induction / Nitrous
1
01-28-2010 12:22 PM
Silver Shadow
Engine Tech / Drivetrain
5
05-27-2008 10:46 AM
Ryan
All Other Honda S2000 Related Discussions
41
05-06-2008 09:24 AM
trizzane
Engine Tech / Drivetrain
6
04-27-2008 12:25 AM
wangdoom
All Other Honda S2000 Related Discussions
4
08-05-2005 05:08 PM


Thread Tools
Search this Thread
Quick Reply: Idle speed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.